Monday, June 1, 2009

Using Weblogic 10.3 Queues & Topics in Soa Suite

If you follow this great guide of Pavan. you can use the JMS Queues / Topics of Weblogic 9.2 in In Soa Suite / But I don't want to do a step back and want to use the Weblogic 10.3 version. With the help of Oracle Support it works now with version 10.3. The only thing I had to change ( if you follow the Pavan Guide ) is to remove the weblogic jar from the jms adapter folder in the Soa Suite J2EE container.
Generate a jdk5 wsfullclient jar and put this in a folder where Soa Suite does not automatically loads this jar. Change the server.xml of the Soa Suite Container where we will add this jar to oracle.bpel.common shared library. Make sure the fullclient reference is before orabpel-thirdparty.jar reference, because this thirdparty also contains wls classes.

<shared-library name="oracle.bpel.common" version="10.1.3">
<code-source path="C:\oracle\prodcuct\10.1.3\soaas_1/bpel/system/classes"/>
<code-source path="C:/java/wlfullclient5.jar"/>
<code-source path="C:\oracle\prodcuct\10.1.3\soaas_1/bpel/lib/orabpel-common.jar"/>
<code-source path="C:\oracle\prodcuct\10.1.3\soaas_1/bpel/lib/orabpel-thirdparty.jar"/>
<code-source path="C:\oracle\prodcuct\10.1.3\soaas_1/bpel/lib/orabpel.jar"/>

Or you can wait for the MLR8 patch.
Now we can use the WLS 10.3 JMS adapters in Oracle BPEL and ESB.


  1. hi there... im having problems with this... what version of jdeveloper are you using? i have does this works for it?
    also, have you seen or done a tutorial for the jdeveloper configuration of this?
    and i noticed you mentioned the MRL8 version of SOA SUITE, is this the one you get when upgrading with 10g Release 3 (10.1.3) Patch Set 4 ( for Microsoft Windows (32-Bit)??

    thanks in advance

    Nico Zapata

  2. Hi , I am using jdev and soa suite with an extra MLR patch on . (from metalink)

    thanks Edwin

  3. hi!, thx for the answer, well now i have some extra doubts.. I have followed pavan's guide, and i still can get any good results...
    i think i have configured correctly the oc4j-ra.xml file, but when it comes to adding the jms adapter to my bpel, that's where i think my mistake is... have u seen or done a guide for this? specially in step 3 of the wizard..
    and one last thing.. can you specify wich mlr patch you told me before so i can download it from metalink?

    my environment is
    weblogic 10gr3
    oracle soa suite

    thanks in advance

    Nico Zapata

  4. Hi,

    I got it working with mlr7. Can you describe the jndi queue and connection factory name in WLS and are they targeted.

    and show me the oc4j-ra.xml and the log.xml errors. and show me the jms wsdl part where the queue name is defined.

    thanks Edwin

  5. hey!, im trying to send you all you need, but it seeems i cant send you xml throug here, do you have a mail or something so i can send you this stuff?

  6. hey!, i solved it.. well half of it... i can send menssage to a queue.. but i can't read them.. trying different configuration now so i can make it run... thx!


  7. hey.. it's me again.. so.. i managed to make this bpel to put messages on a queue... but i still can make a dequeue...i've read in several pages that this is an issue, but no-one had an answer for this... i think this may be something of the configuration of the queue.. but not sure about it..
    do you have any idea of what could be happening?

    Nico Zapata

  8. Ok,

    Can you send me some logging to biemond at gmail dot com

    very strange , I think default wls enables dequeue and enqueue.

    you can try to do it from java

    thank Edwin

  9. hey, thaks for all your help... but reading a little more I found out that version of weblogic needs a patch (6316554 to be more precise..) wich fix the consume functionality os jms adapters with weblogic... I assumed that that fix comes with the mlr#7 patch from metalink so I'll change my course and try to connect OC4J and Weblogic through activeMQ o another thing until i can get my hands over the patch..
    thanks a lot

    Nico Zapata

  10. Hi,

    I am using SOA 11g. I have deployed a resource adapter on soa_server1 in weblogic. The resource adapter rar contains libraries like jdom.jar, log4.jar etc.

    when i run an outbound transaction i am hitting NoClassDefFound exception for jdom.Document. How can i specify in the resource adapter to used the classes contained in the RAR. In SOA 10g this was specified in oc4j-ra.xml file.

    Any information will be really helpful.


  11. Hi,

    when I take a look at the bam adapter rar in \Oracle_SOA1\soa\connectors then you just have to put them in the root of the zip.
    and a reference to these jars in your manifest.
    Manifest-Version: 1.0
    Class-Path: 123.jar 234.jar

    thanks Edwin

  12. do u have any idea
    about this error which i am facing when connecting SOAP to web services




    d. S:Server

    e. ClusterRoutingTubeUtils weblogic.wsee.jaxws.cluster.ClusterRoutingTubeUtils@1d114d9d not ready, no WseeClusterRoutingRuntimeMBean/WseeRuntimeMBean